Author Topic: nvidia+5.4.7 kernel working how to  (Read 193 times)

moddingden

  • Administrator
  • Newbie
  • *****
  • Posts: 35
    • View Profile
nvidia+5.4.7 kernel working how to
« on: January 03, 2020, 05:47:56 PM »
Hi; ok  so i ran across the  nvidia forums and an answer from someone there  stating to a user that he was trying to use a kernel compiled  w gcc 9.0. this sent me on a path to this site:
https://askubuntu.com/questions/1140183/install-gcc-9-on-ubuntu-18-04

sudo add-apt-repository ppa:jonathonf/gcc-9.0
sudo apt-get install gcc-9  was norberts answer

later answer was :
sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt update
sudo apt install gcc-9 by ISanych

this was added later:
just as a reminder to people reading this sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-9 60 --slave /usr/bin/g++ g++ /usr/bin/g++-9 JHBonarius
now this last line gives and error if you use top repo but does work gcc 9.0 is default .

I use ukuu(newer version pay for $10) to get the kernel, not an rc final.
now before this with nvidia 440.36  was a no dice and complained about firmware missing still working on that but my net works.
dkms would not install etc .

after adding the above and trying it later  it worked (today was tried and setup).

linux it never fails to  show how great the folks are that are willing to help.

 

SMF spam blocked by CleanTalk