Recent Posts

Pages: 1 [2] 3 4 ... 10
General Discussion / Re: Hi @all
« Last post by Darin on August 28, 2020, 03:57:04 AM »
I'm glad to hear that and thank you for the update. There will be an update to the base with a newer kernel and ZFS completely taken out. If you ever have issues please post into the forums and we can get to it as soon as we can. I work a lot of hours so it might be a few days to hear from me but I will respond and try to fix the issue.
General Discussion / Hi @all
« Last post by onabi on August 23, 2020, 03:58:14 PM »
Just want to say hi!
I'm using V6 now for 6 weeks after abandoning LMDE and everything's good so far.  :)
Software Issues / Re: SG6 install - zfs
« Last post by Darin on July 13, 2020, 12:14:12 AM »
Here is the problem with the ZFS file system, the license is not open source and most distros do not or will not support it on any kernel version higher 5.5 series. Until some legal stuff gets worked out and Linus gives a go ahead to put it back into the kernel then it is out. The update to the SG6 with have it taken completely out and when it is good to go I will put it back in. I am not going to patch the kernel that will violate the the terms of it.
Software Issues / Re: SG6 install - zfs
« Last post by mclad on July 04, 2020, 06:30:46 PM »
 don't trust and distro installers for ZFS and even when they work they usually demand an entire drive. So for all my linux distros which now most all go to my zpools I do:
1. Install to an ext4 partition, check firmware, upgrade
2. Manually install (or build eg for Clear Linux) zfs-dkms zfs-initramfs/dracut and zfsutils-linux
3. zpool import my existing bpool (crippled to work with grub) and rpool (or create zpools) if a clean machine)
4. make new datasets mounted to /, /boot, /home/mike, /root, maybe some others
5. zfs mount new datasets and my common across distros datasets (Bin,Documents,Downloads,Music,Pictures,Videos)
6. rsync from the ext4 partition to the bpool and rpool mounted zfs datasets
7. chroot in, fix up /etc/fstab, hostname etc. AND take initial zfs snapshot
8. update-grub - after fstab bind mount below as I have single place for /grub and hence grub.cfg in EFI System Partition so /etc/fstab for all my distros on a machine have first few lines like so:
# only if / not in zfs rpool have:: UUID=xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx  /  ext4  defaults,errors=remount-ro  0  2
UUID=XXXX-XXXX  /boot/efi  vfat  defaults  0  0
/boot/efi/grub  /boot/grub  none  defaults,bind  0  0
9. reboot into shiny new distro nicely in zfs
Release Announcements / Kernel 5.7.3
« Last post by Darin on June 26, 2020, 09:36:23 PM »
Here is an unpatched 5.7.3 kernel for anyone who needs the newest Kernel. Only works on the SuperGamer V6 release.

Simply unzip the folder where ever you wish, open a terminal in the folder and run this command:
Code: [Select]
sudi dpkg -i *.deb
Release Announcements / Re: SuperGamer V6 Release
« Last post by Darin on June 24, 2020, 07:13:02 PM »
Could you please try again as the link works on this end and from DistroWatch, please try the link again and report back.
General Discussion / Re: wanted to say hi and try this distro out
« Last post by Darin on June 22, 2020, 09:56:35 AM »
I hope this suits your needs.
General Discussion / wanted to say hi and try this distro out
« Last post by mrskripka on June 21, 2020, 01:39:39 PM »
wassup i downloaded and currently installing supergamer il try it out i was switching distros for over month now hope this will suit me!
Release Announcements / Re: SuperGamer V6 Release
« Last post by mr.nice on June 21, 2020, 04:15:27 AM »
Hello Darin, thank you for the release!

The google drive link does not work for me.
Could you please provide me an different download link?

Thank you!

Best regards
Software Issues / Re: SG6 install - zfs
« Last post by Darin on June 15, 2020, 10:16:33 AM »
I agree it is, this is based on Ubuntu 20.04 with the core of it and the installer being part of the core. The Ubiquity installer is the issue. I am moving away from it and towards a different installer in future releases and they might not even be based on Ubuntu. I found out that Ubuntu's patches mess up the Nvidia drivers and worked to fixed them until I just built my own kernel. I went round and round with the amdgpu open source driver until I found a fix for some of the onboard graphics. They rushed this release out and there are issues. I actually prefer the 16.04 release as it is polished but progress has to go forward, I just wished they put the same amount of time into it. I will do some testing to see if I find a simple fix but I am guessing that the mkfs program is the issue or gparted as I have not dived into the install scripts yet.
Pages: 1 [2] 3 4 ... 10
SMF spam blocked by CleanTalk