Software => Software Issues => Topic started by: afeher on June 14, 2020, 11:31:30 PM

Title: SG6 install - zfs
Post by: afeher on June 14, 2020, 11:31:30 PM
if select ZFS:  the install crashing at the next step - during write user datas.
Title: Re: SG6 install - zfs
Post by: Darin on June 15, 2020, 02:05:57 AM
That is the Ubiquity installer that is standard on Ubuntu 20.04 base distros. I have plans on removing it completely and either finding a different installer or move on from Ubuntu as this release drove me crazy trying to fix things. ZFS is still experimental on Ubuntu no matter what they say.
Title: Re: SG6 install - zfs
Post by: afeher on June 15, 2020, 04:45:28 AM
I belive, it is not a ZFS problem. I used ZFS on fedora more than 5 years without any problem. it is problem of the  install script, in the case of ZFS selection.
Title: Re: SG6 install - zfs
Post by: Darin on June 15, 2020, 10:16:33 AM
I agree it is, this is based on Ubuntu 20.04 with the core of it and the installer being part of the core. The Ubiquity installer is the issue. I am moving away from it and towards a different installer in future releases and they might not even be based on Ubuntu. I found out that Ubuntu's patches mess up the Nvidia drivers and worked to fixed them until I just built my own kernel. I went round and round with the amdgpu open source driver until I found a fix for some of the onboard graphics. They rushed this release out and there are issues. I actually prefer the 16.04 release as it is polished but progress has to go forward, I just wished they put the same amount of time into it. I will do some testing to see if I find a simple fix but I am guessing that the mkfs program is the issue or gparted as I have not dived into the install scripts yet.
Title: Re: SG6 install - zfs
Post by: mclad on July 04, 2020, 06:30:46 PM
 don't trust and distro installers for ZFS and even when they work they usually demand an entire drive. So for all my linux distros which now most all go to my zpools I do:
1. Install to an ext4 partition, check firmware, upgrade
2. Manually install (or build eg for Clear Linux) zfs-dkms zfs-initramfs/dracut and zfsutils-linux
3. zpool import my existing bpool (crippled to work with grub) and rpool (or create zpools) if a clean machine)
4. make new datasets mounted to /, /boot, /home/mike, /root, maybe some others
5. zfs mount new datasets and my common across distros datasets (Bin,Documents,Downloads,Music,Pictures,Videos)
6. rsync from the ext4 partition to the bpool and rpool mounted zfs datasets
7. chroot in, fix up /etc/fstab, hostname etc. AND take initial zfs snapshot
8. update-grub - after fstab bind mount below as I have single place for /grub and hence grub.cfg in EFI System Partition so /etc/fstab for all my distros on a machine have first few lines like so:
# only if / not in zfs rpool have:: UUID=xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx  /  ext4  defaults,errors=remount-ro  0  2
UUID=XXXX-XXXX  /boot/efi  vfat  defaults  0  0
/boot/efi/grub  /boot/grub  none  defaults,bind  0  0
9. reboot into shiny new distro nicely in zfs
Title: Re: SG6 install - zfs
Post by: Darin on July 13, 2020, 12:14:12 AM
Here is the problem with the ZFS file system, the license is not open source and most distros do not or will not support it on any kernel version higher 5.5 series. Until some legal stuff gets worked out and Linus gives a go ahead to put it back into the kernel then it is out. The update to the SG6 with have it taken completely out and when it is good to go I will put it back in. I am not going to patch the kernel that will violate the the terms of it.